A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2026 - 12:45 UTC
Investigating
We’re investigating an issue causing delays in email delivery. Some users may also be unable to view emails after logging in. All messages are safely queued and will be delivered once the issue is resolved. We apologize for the inconvenience and appreciate your patience.
Posted Jan 16, 2026 - 12:31 UTC
This incident affected: Hostinger Email (Hostinger Mail).