Hostinger Horizons Downtime

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 03:24 UTC

Investigating

We’re investigating a service disruption affecting users on the Hostinger Horizons platform. Our team is working to identify the cause and restore normal operations as quickly as possible. We apologize for the inconvenience caused.
Posted Nov 18, 2025 - 21:03 UTC
This incident affected: Hostinger Horizons (Hostinger Horizons Editor).