Horizons website previews might not be working
Incident Report for
Hostinger
Resolved
This incident has been resolved.
Posted
Nov
18
,
2025
-
16:09
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Nov
18
,
2025
-
14:57
UTC
Update
Cloudflare services were partially restored, however some region are still experiencing issues
Posted
Nov
18
,
2025
-
14:19
UTC
Update
One of our providers, Cloudflare, is currently experiencing network issues. It directly impacts website previews in our Horizons product.
Posted
Nov
18
,
2025
-
12:11
UTC
Update
The 3rd party issue has been identified. We're waiting for a fix.
Posted
Nov
18
,
2025
-
12:03
UTC
Identified
The issue has been identified.
Posted
Nov
18
,
2025
-
11:55
UTC
Investigating
We're having issues with website previews. They might not be working or be unstable for a while.
Posted
Nov
18
,
2025
-
11:53
UTC
This incident affected: Hostinger Horizons (Hostinger Horizons Preview).
×
Subscribe to Incident
Subscribe to updates for
Horizons website previews might not be working
via . You'll receive .