Cloudflare reports that a fix has been implemented and the incident is resolved. You can view the details on Cloudflare's status page here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7. We are currently monitoring the situation to ensure all services are fully operational.
Posted Nov 18, 2025 - 14:55 UTC
Update
Cloudflare is reporting that services are starting to recover. While the situation is improving, you might still run into occasional error messages or slow loading times while they finish their repairs. Currently, Horizons sandboxes, payment providers such as PayPal, Coingate, and Paysera, Hostinger Account logins and Hostinger Mail are affected. You can view the ongoing incident on Cloudflare's status page here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7. We are actively monitoring the situation and working toward a resolution. We will continue to provide updates as more information becomes available.
Posted Nov 18, 2025 - 13:57 UTC
Update
Cloudflare is reporting that services are starting to recover. While the situation is improving, you might still run into occasional error messages or slow loading times while they finish their repairs. Currently, Horizons sandboxes, Hostinger Mail and payment providers such as PayPal, Coingate, and Paysera are affected. You can view the ongoing incident on Cloudflare's status page here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7. We are actively monitoring the situation and working toward a resolution. We will continue to provide updates as more information becomes available.
Posted Nov 18, 2025 - 13:13 UTC
Identified
Cloudflare is reporting that services are starting to recover. While the situation is improving, you might still run into occasional error messages or slow loading times while they finish their repairs. You can view the ongoing incident on Cloudflare’s status page here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7 We are actively monitoring the situation and working toward a resolution. We will continue to provide updates as more information becomes available.
Posted Nov 18, 2025 - 12:43 UTC
Investigating
One of our providers, Cloudflare, is currently experiencing network issues that may impact users who rely on Cloudflare protection for their websites. You can view the ongoing incident on Cloudflare’s status page here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7 We are actively monitoring the situation and working toward a resolution. We will continue to provide updates as more information becomes available